openssl101r

Source package: openssl101r

Repository: backports

Description

Special version of openssl for old PHP packages – 5.2 and 5.3.

Can be installed with system version.

If some packages need to be rebuilded with that version of openssl, then you need to add into makefile, debian/rules this code:

PKG_CONFIG_PATH:=
ifneq ("$(wildcard /opt/openssl101r/usr/include)","")
# backported openssl 1.0.1
CFLAGS += -I/opt/openssl101r/usr/include -L/opt/openssl101r/usr/lib
PKG_CONFIG_PATH:=$(PKG_CONFIG_PATH)/opt/openssl101r/usr/lib/pkgconfig:
endif

Last Updated on 29.05.2022 by Sergey Dryabzhinsky