Пакеты для Ubuntu 12 и Debian 7 будут удалены 2022-05

Поддержка Ubuntu 12 и Debian 7 заканчивается.

  • пакеты для Ubuntu 12 и Debian 7 будут собираться-обновляться до 2022-01
  • пакеты для Ubuntu 12 и Debian 7 будут удалены после 2022-05

Так же, после 2022-01 пакеты для arm64 будут собираться для Raspberry PI 4B (Cortex A72).

Реструктуризация репозитория go

Так как для пакетов используются оригинальные бинарные сборки от Google, то:

  • не имеет смысла собирать под все релизы дистрибутивов одно и то же
  • нет зависимостей от libc и др. библиотек, которые могут различаться в релизах
  • будет оставлены несколько «стабильных» релизов от каждого дистрибутива:
    • Debian 9
    • Debian 10
    • Ubuntu 16
    • Ubuntu 18

Сборка пакетов для arm64 на Raspbian Pi 3 работает со сбоями

Не все пакеты могут собраться — мало памяти, 1Гб не хватает.

Те пакеты, что собраться не могут на RPI3 — будут собираться через транслятор qemu-static под cortex-a53.

Приостановка сборок пакетов [обновлено]

Сборка пакетов приостановлена — делаю разделение сборок для архитектур на отдельных вирт.машинах.


Сборочные машины запущены, пакеты будут собираться чуть быстрее.

Сборка пакетов для armhf и arm64 на Raspbian Pi прекращена [обновлено]

Оба сервера на Raspbian Pi 2B и 3B вышли из строя.

Как только я их починю — пакеты снова будут собираться специально на них.

Пока пакеты для архитектур armhf и arm64 будут собираться с помощью qemu.


@2021-02-23: Обе сборочных машинки снова в бою

Пакеты для Ubuntu 20.04 собираются по возможности

Пакеты для Ubuntu 20.04 в официальном репозитории доступны только частично.

По-этому не все пакет можно пересобрать.

Придется подождать первого обновления 20.04.1.

Прекращение поддержки Ubuntu Lucid

Дистрибутив слишком сильно устарел.

Поддержка сборки пакетов стала требовать слишком много усилий.

Официальная поддержка давно закончилась.

И он больше не используется мной ни на одном сервере или проекте.

Все пакеты для Ubuntu Lucid будут удалены в течении ближайших двух месяцев.

Прекращение поддержки дистрибутивов Raspbian и Devuan

Пакеты для Raspbian совпадают с пакетами для Debian. Отдельная поддержка не имеет смысла. Можно просто подключить репозитории для debian-{release}.

Дистрибутив Devuan мной более нигде не используется. Дальнейшая поддержка не имеет смысла.

Пакеты будут удалены в течении ближайших месяцев.

Репозиторий на Launchpad переполнен

У репозитория на Launchpad закончилось выделенное место.

Запрос на увеличение доступного места отправлен.

Пакеты пока собираются только для локального репозитория.


@2019-05-25: Место в репозитории увеличено, удалены пакеты для Ubuntu Precise.